Qomo Linux

  • 状态 待关闭
  • 完成百分比
    100%
  • 任务类型 缺陷报告
  • 模块 devel
  • 指派到 不要
  • 操作系统 All
  • 严重性 严重
  • 优先级 普通
  • 报告版本 1.1.0
  • 延期到版本 未决定
  • 延期到日期 未决定
  • 投票
  • 不公开的
属于项目: Qomo Linux
任务打开人: realasking - 2010年11月29日
最后修改人: W-J - 2010年12月02日

FS#307 - 在Qomo1.1.0里compat-gcc-34-c++仍然无法安装

Bug简介

在Qomo1.1.0里compat-gcc-34-c++仍然无法安装

附加信息

root@realpuma /home/realasking/src pts4 # yum install compat-gcc-34-c++
已加载插件:refresh-packagekit
设置安装进程
解决依赖关系
–> 执行事务检查
—> 软件包 compat-gcc-34-c++.i386 0:3.4.6-18.1 将被 安装
–> 处理依赖关系 libstdc++ < 4.5.0,它被软件包 compat-gcc-34-c++-3.4.6-18.1.i386 需要
–> 完成依赖关系计算
错误:Package: compat-gcc-34-c++-3.4.6-18.1.i386 (extra)

      Requires: libstdc++ < 4.5.0
      已安装: libstdc++-4.5.0-3.i386 (@a-Base)
          libstdc++ = 4.5.0-3
      Available: libstdc++-4.5.0-2.i386 (core)
          libstdc++ = 4.5.0-2

You could try using –skip-broken to work around the problem

请描述一下Bug重现的步骤:

  1. 第一步,yum install compat-gcc-34-c++

然后报错。

Project Manager
W-J commented on 2010年12月02日 01:57:01, Thu

系统中已经将compat-gcc-34 移除。

realasking commented on 2010年12月02日 07:26:57, Thu

那么能否再重新增加这个旧版的gcc?
有很多软件用新版的gcc编译的时候会出现DSO错误,
如果手工去一个一个的改makefile的话太麻烦了。

载入...

Available keyboard shortcuts

Task List

Task Details

Add/Edit Task

TODO:complete the list
for accesskey usage different shortcuts on Windows, Mac, Linux .., currently shown for Firefox