Qomo Linux

  • 状态 已分派
  • 完成百分比
    0%
  • 任务类型 缺陷报告
  • 模块 apps
  • 指派到
    hudson
  • 操作系统 All
  • 严重性
  • 优先级 普通
  • 报告版本 3.1.0
  • 延期到版本 未决定
  • 延期到日期 未决定
  • 投票
  • 不公开的
属于项目: Qomo Linux
任务打开人: yanqian - 2012年06月23日

FS#682 - 无法编译安装qterm 0.5.12

Bug简介

QTerm 0.5.12下载自:http://www.qterm.org/wiki/index.php/Downloads 平时经常用这个软件上BBS等,在Qomo 3.1上无法编译安装,错误信息如下。

附加信息

$ cmake ..
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt4: /usr/lib/qt4/bin/qmake (found suitable version "4.7.4", required is "4.5.0")
CMake Error at /usr/share/kde4/apps/cmake/modules/FindQt4.cmake:514 (MESSAGE):
  Invalid Qt version string given: "4.5.0", major version 4 is required, e.g.
  "4.0.1"
Call Stack (most recent call first):
  /usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:420 (find_package)
  /usr/share/cmake/Modules/FindKDE4.cmake:95 (FIND_PACKAGE)
  CMakeLists.txt:11 (find_package)


-- Configuring incomplete, errors occurred! 

请描述一下Bug重现的步骤:

tar xvf qterm-0.5.6.tar.bz2
cd qterm-0.5.6
mkdir build
cd build
cmake ..

yanqian commented on 2012年06月24日 08:16:31, Sun

我将之前旧版Qomo上编译安装的qterm相关文件打包,在3.1上释放后也可以正常用,先放这里,或许有其他人也用。
或许自己也应该学习下RPM打包,那样直接就做一个RPM包了,可惜目前不会。

载入...

Available keyboard shortcuts

Task List

Task Details

Add/Edit Task

TODO:complete the list
for accesskey usage different shortcuts on Windows, Mac, Linux .., currently shown for Firefox